What iOS products are supported?

We only support iOS 8 or later, so Zello will not work on older iPhones that cannot install OS 8 (iPhone 2G, 3G, and 4G). iPhone 4s and later models are supported.

Was this article helpful?

0 Comments

Article is closed for comments.

13 out of 13 found this helpful